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There are three main steps to Quality Control protocol for DTI 

1.) DICOM conversion – Download and conversion of files to .nhdr files for use in programs 

2.) DTIPrep Automatic QC – Execution of a protocol script to automatically QC scans 

3.) Visual DWI & DTI QC – Visual recheck of DITPrep QC results, preliminary fiber tracking, and 

visual check of signal loss and anomalies  

 

I. DICOM conversion  

 A. Checking for and preparation of incoming data 

Step Description Action 

1 Go into the CHDI directory cd /projects4/CHDI_TrackHD/ 

2 Check recent downloads tail -40 downloadlog.txt 

3 go into the Data repository cd Data 

4 unzip corresponding tar file gtar –xzf  <tar.gz file> 

5 move subject folder into 

HDNI folder 

mv HDNI/<xxxx> ../HDNI 

6 Update Wiki table http://pandora.ia.unc.edu/wiki/index.php/HDNI:General 
 

 B. Conversion of Dicom to NHDR  

Step Description Action 

1 Go to subject folder cd /projects4/CHDI_TrackHD/HDNI/<subjectID> 

2a. Run Dicom conversion DicomConv_HDNI.script <subjectID> <fullpath to 

DICOMfolder> 

2b. Run Dicom conversion for two 

Dicom folders 

DicomConv_HDNI_MergeTwo.script <subjectID> 

<fullpathtoDICOMfolder1> <fullpathtoDICOMfolder2> 

 

2c. Add option Phillips for all 

Philips datasets 

DicomConv_HDNI.script <subjectID> <fullpath to 

DICOMfolder> Phillips 

2d. Add option Zoltan at the end 

for all zoltan datasets (only 

works for 2 Dicom folder 

present) 

DicomConv_HDNI_MergeTwo.script <subjectID> 

<fullpathtoDICOMfolder1> <fullpathtoDICOMfolder2> 

Zoltan 

3 Verify correct conversion with 

DTIPrep 

DTIPrep – In DTIPrep GUI, click on “File” and then 

“Open DWI” to open the .nhdr file 

4 Update Wiki table http://pandora.ia.unc.edu/wiki/index.php/HDNI:General 
 

II. DTIPrep Automatic QC 

 A. Initial Visual QC  

 i. In DTIPrep, review baseline images in axial, sagittal, and coronal views. Note any 

issues of coverage, i.e. inferior axial slices missing such as the cerebellum and temporal 

lobe, and/or superior slices missing.  Second, notice any artifacts or motion in these 

scans, i.e. “venetian blind” effect, checks, etc.  DTIPrep will automatically detect  

and extract most of these artifacts.  For more details on these artifacts see section III - 

“Visual DWI & DTI QC” 
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Note: In this study, coverage issues automatically received a rating of “Borderline” with 

rankings of minor, intermediate, and severe appearing in the notes.  Depending on the 

type of analysis, full coverage may be required to produce a suitable atlas. 

 

Figure 1.1 

“Bad coverage (severe)” a scan missing 

nearly all of the cerebellum and a large 

portion of the temporal lobe 

 

 

 

     Figure 1.2 Good coverage 

 

 B. Run Protocol 

 i. Click on the “Protocol” tab on the left side of the 

screen.  Select “Load” and choose the 

appropriate protocol script.  Click on 

RunByProtocol button on the bottom of the 

DTIPrep box. 

 ii. The results for each gradient check read Pass or 

Fail in the command line, depending on the 

parameters and threshold set in the protocol. [For this study the first two checks, the 

Image information check and Diffusion check, are inconsequential.  As well, the failure 

threshold is set at 30% for all scans except merged Philips data from two scans, which is 

60%] 

 

 

Figure 1.2 

Command line 

showing results 

overlaying DTIPrep 

GUI with protocol 

loaded 

 

 

 

 

 iii. After the protocol runs, select 3D view tab and click on the sphere icon as well as the F 

and I icons to view distribution of directionality.  The F represents the directions before 

automatic QC.  These directions are represented in blue.  The I represents the directions 

left after the automatic QC, labeled in green. Note any major unevenness in spatial 

distribution.  [For the purposes of this study, “major unevenness in spatial distribution” 

is defined generously.  For example, no documentation of spatial gaps occurs unless a 

visual estimation equals approximately 40% or more of the sphere.] 

 iv. As a reconfirmation of the Pass/Fail results from DTIPrep based on the set threshold 

percentage, view the QC Report and note the number of excluded gradients over the 

total number of directions in the dataset.  [Consider that the number of DWIs showing 

in the ~QCed.nhdr file may not add up to the original total minus the exclusions due to 

baseline averaging] 
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Figure 1.3 3D View displaying distribution of direction of gradients before and after automatic QC by 

DTIPrep 

 

 

III.  Visual DWI & DTI QC 

 A. Visual DWI QC 

 i. Open ~_QCed.nhdr file created by DTIPrep  

 ii. Selecting a representative slice, examine axial, sagittal and coronal views across all 

DWI gradients; adjust contrast and scroll through other slices as necessary.  

 iii. Document any perceived image quality issues; i.e. “venetian blind” effect (horizontal 

stripes), “checkers” effects - particularly in axial views, motion artifacts, geometric 

artifacts, “bar” artifacts, distortion, “Z-stripe” artifacts, gradients with intensity 

differences between slices and any other anomalies. 

 iv. Run the extraction script, ExtractGradDir.py on the ~QCed.nhdr file, to remove 

directions deemed appropriate for manual exclusion based on image quality.  These 

include gradients with “venetian blind” effects (Fig. 1.4), “checkers” effects Fig. (1.5), 

motion artifacts as well as gradients containing one or more axial slices displaying 

higher or lower intensities across the whole slice (Fig. 1.7). 

 a) Certain artifacts may occur across most or all gradients.  In these cases, perform 

further analysis and documentation of the artifact.  If the artifact is associated with a 

particular scan, that scan may receive a “Fail” rating.  

 b) If the artifact is present in multiple scans from the same protocol a determination of 

a “Borderline” rating might be made in the interest of preserving data.  [In this 

study, Zoltan-protocol-related distortion was associated with gradient-consistent 

artifacts (see Figures 1.8-1.11)]  Following this conclusion, carefully record the 

nature and location of the artifact and include this information in the QCReport on 

the TrackHD website (see section IV.) and on the wiki page. 
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Figure 1.4 “Venetian Blind” Effect A clear example of the “venetian blind” artifact as seen in DTIPrep 

 

 v. Record the amount and gradient numbers of manually excluded directions on wiki page: 

http://pandora.ia.unc.edu/wiki/index.php/HDNI:General 

 

Figure 1.5 (left) “Checkers” artifact shown in an axial slice in 

a DWI gradient 

 

This artifact occurs most commonly in scans that also have a 

three-stripe blurring effect.  In this study, some of the Siemen’s 

protocol dataset contained these three-stripe blur artifacts as 

shown below in Fig. 1.6 

 

 

 

Figure 1.6 (right) “Three-stripe 

blur” artifact in sagittal view of 

DWI gradients 

 

 

 

 
 

 

 

 

 

Figure 1.7 (left) Frontal Distortions 

Distortion clearly visible in a baseline 

image from a Zoltan-protocol dataset 
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Figure 1.8 DWI with a high-intensity axial slice as displayed in DTIPrep 

Although in the sagittal view this slice appears only halfway bright, both the axial and 

coronal views show a consistent difference in intensity compared to the surrounding 

slices 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1.9 Distortion-related artifact “Z stripe”           

running in the anterior/posterior direction and 

visible in axial slices and occasionally in 

sagittal view. Prominent in Zoltan protocol. 

 

Figure 1.10 One type of geometric 

artifact, triangular in shape, possibly 

caused by eddy current motion 



7 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1.11 Another type of triangle-shaped geometric artifact, outlined on the right 

 

Figure 1.12 “Double-bar artifact” outlined on the right, there are other “bar artifacts” visible in this 

figure, seen in conjunction with distortion particularly in Zoltan protocol. 
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Figure 1.13 Lateral sulcus anomaly present in all protocols, but more consistently in Zoltan dataset 

 

 

Note: Beware of “false artifacts” The issue below is due only to the positioning of the head and not a 

scanner or acquisition related artifact 

Figure 1.14 Falsely perceived anomaly or artifact - A superior indentation appears to “travel” in the 

anterior-posterior direction as the sagittal slices progress, shown with arrows.  This can occur in cases 

where the axial direction is “yawed” or rotated in relation to the sagittal plane. (shown in next figure, 

1.15). 
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Figure 1.15 Rotated axial slices – As the sagittal plane crosses the medial plane of the brain at an 

angle, the cross-point appears as an “indentation” in the sagittal view, seen above and in Figure 1.14. 
 

B.  Preliminary DTI QC (glyphs and fiducial seeding) 

 i. Convert ~QCed_extracted.nhdr (or ~QCed.nhdr if there are no manual extractions) files 

into ~.nrrd files using CreateDTIImages.script [for Zoltan cases, use 
HackZoltanBvalue.script before CreateDTIImages.script]. Open ~float.nrrd file in 

Slicer under File>Add Volumes>Apply 

 ii. Glyph check 

 a) Under the “Volumes” module, select the “Display” drop down menu and change the 

Scalar Mode to “Color Orientation” 

 b) Select all three boxes in the “Glyphs Visibility Display” area  

 c) Adjust spacing setting as necessary to clearly see the individual glyphs 

 d) Look at the directionality of the glyphs in the Axial window, examine the Corpus 

Callosum, genu and splenium, to ensure that the glyphs are following the tract 

 e) Do the same with the coronal section of the CC, which can be seen in the Coronal 

slices.  After QC check, deselect the three glyph visibility boxes 

 

 

 

 

Figure 2.1 

 Selecting 

“Color 

Orientation” 

 in the Scalar 

Mode 

 

 

Cross point of sagittal slice 

and medial plane of the brain 
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Figure 2.2 Viewing Glyph Directions in Slicer – Selecting “glyph visibility” and changing the spacing 

 

 iii. Tracking using Fiducial Seeding 

 a) Select the “Fiducials” Module and click on the arrow icon in the top icon toolbar, 

selecting “Use mouse to create-and-place persistently” to place seeds for five tracts: 

Corpus Callosum (genu, splenium, coronal); Cingulum, Uncinate, Arcuate, and 

Internal Capsule 

 b) Directionalities are demonstrated in the color map along the following orientations: 

red is left/right, green is anterior/posterior, and blue is inferior/superior 

 

 

Figure 2.3 Incorrect Glyph Directions in Slicer – It is necessary to regulate this problem before 

continuing with QC, otherwise the resulting tracts are incorrect 
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 c) Seedmap labeling of tracts 

 CC – Starting in the Sagittal plane, identify the CC, which typically appears red 

in DTI Color Orientation maps.  It is bounded superiorly by the cingulum and 

inferiorly by the lateral ventricles.  Place a fiducial in the most anterior part to 

mark the genu.  Place another label in the posterior section of the CC, to mark 

the splenium.  In the coronal view, mark the CC at its vertex to track the coronal 

fiber bundles of the CC.   

 Cingulum – In the Coronal view, superior to the CC, is the cingulum appearing 

normally as two green “teardrop” shaped bodies.  Mark the left side cingulum. 

 Uncinate – In the axial view, move inferiorly through the slices.  Lateral to the 

brainstem, the anterior tip of the inferior longitudinal fasciculus appears 

blue/purple.  Place a fiducial on the right side to mark the uncinate. 

 Arcuate (2 fiducials) – In the axial view, locate the arcuate.  Lateral to the 

inferior fronto-occipital fasciculus/inferior longitudinal fasciculus, and at the 

temporo-parietal junction towards the posterior direction of the brain, lies a 

blue/purple portion of the arcuate.  Place a fiducial here.  “The fronto-parietal 

portion of the arcuate fasciculus encompasses a group of fibers with antero-

posterior direction (green)” that can be found lateral to the corticospinal tract a 

few axial slices superior from the last fiducial, place a second marker here. 

(Catani et. al., 2008, “A diffusion tensor imaging tractography atlas for virtual in 

vivo dissections”) 

 

Figure 3.1 Placing Fiducial Label Seeds to track the Uncinate, Cingulum and Corpus Callosum (genu, 

splenium, and coronal section) 
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 Place one fiducial in 

posterior portion 

(normally blue/purple) of 

the arcuate. (see left) 

Place another several 

slices up in the superior 

direction next to 

corticospinal tract, the 

arcuate is usually green 

here. (see right) 

 

 

 

 Internal Capsule – In the coronal view, medial to the arcuate and inferior 

longitudinal fasciculus and lateral to the CC is the internal capsule.  Usually, it is 

mostly blue/purple.  Place 2-3 fiducials in the internal capsule, particularly, in 

the most inferior part of the IC that is blue/purple 

 

 

 

Figure 3.2 Placing Fiducial Label Seeds to track the Internal Capsule (IC) in Slicer 

 

 

 d) Diffusion Tractography for preliminary QC 

 Under “Modules”, go to Diffusion > Tractography> Fiducial Seeding; Choose 

“L” from the “Select FiducialList or Model” drop down menu, then “Create 

New Fiber Bundle” from the “Output Fiber Bundle Node” drop down menu.  

 Set the Stopping Value to 0.10, the Fiducial Seeding Region (mm) to 6.0 mm, 

and the Fiducial Seeding Step Size (mm) to 1.0 mm. 
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Figure 3.3 Diffusion Tractography of Fiducial Labels 

 

 [Optional] To increase speed and performance, it is possible to change the 

display of tubes to lines.  Go to Diffusion > Tractography > Fiber Bundles.  

Click on the “Lines” tab and select the “Visibility” box.  Click on the “Tubes” 

tab and deselect the “Visibility” box. 

Figure 3.4 Cingulum fiber bundle tractography viewed with Line display 

 

 Return to the Fiducials module, deselect any labels that are undesired to appear 

in the 3D Viewing pane.  Look to ensure that all tracts are present.  If they are 
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incomplete, add more fiducial seeds in areas that are lacking.  Or, move the 

existing labels using the “Use mouse to Pick-and-Manipulate persistently” 

option under the hand icon.   

 

 

Figure 3.5 Uncinate label only selected, shown with Sagittal slice in 3D window 

 

 

 

 e) Record any unusual tracts 

 

If the above steps are not successful, note 

any incomplete or missing tracts. 

 

Figure 3.6 (right) displays an unusual-

looking genu and splenium.  In this 

example, the pathology of the subject 

(observe enlarged lateral ventricles), rather 

than tractography, is the suspected cause of 

the difference and was appropriately 

documented in the visual QC notes. 
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C. Visual QC for Signal Loss and Anomalies in the Scalar Diffusion Parameters 

 i. CreateDTIImages.script created the last of the separate scalar diffusion parameter files 

 ii. In ITK SNAP, open each scalar diffusion parameter ~.nrrd file – either reviewing them 

individually or using the “multisession cursor” option to scroll through the multiple 

images at once. Fractional Anisotrophy – FA; Mean Diffusivity – MD; Axial Diffusivity 

– AD; Radial Diffusivity – RD 

Figure 4.1 “Multisession Cursor and Crosshairs tool on AD and MD NRRD files” 

 

 a) Adjust the contrast as necessary in Tools>Image Contrast, manipulate the graph to 

change the darkness and brightness of the images 

 

 b) Visually check all slices for signal loss/noise represented by pixelated bright spots in 

the FA file and dark spots in the MD, AD, and RD files. 

 

 Look for clusters of this 

perceived signal loss.  If 

present, click the 

Crosshairs tool in the area 

and review the intensity 

information.  In the FA, 

anatomy should not equal 

more than 1.0.   

 

 

 

 

Figure 4.2 Adjusting Image Contrast in ITK SNAP 

 

In the MD, RD, and AD files, it should not be less than zero.  If these intensities are more than 

1.0 and less than 0, note the area for signal loss. 
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Figure 4.3 Signal Loss demonstrated in FA image in Right Pre-Frontal Lobe 

 

 Observe that some signal loss in the orbital regions is typical 

 

 
Figure 4.4 Diagonal NRRD artifact displayed in ITK SNAP, FA and MD images respectively 

This case was subsequently failed as a result of this issue with image-acquisition 

 

 c) During the visual check, also note any anomalous regions that may be due to 

anatomical lesions or problems in image acquisition.  In this study, five types of 

artifacts were identified in the scalar diffusion files: diagonal NRRD artifact, 

possible motion artifacts, wrapping artifacts, a pre-frontal anomaly traced to the 

Philips protocol, and distortion-related signal loss artifacts.   
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 Diagonal NRRD artifact, Figure 4.4 demonstrates this diagonal striping artifact. 

The MD image reveals the large extent of the brain area affected by this issue. 

 

 

 

 

Figure 4.5  

(left)  

Possible 

motion 

artifacts in 

the NRRD 

files 

 

 

 

Figure 4.6 

(right) 

Wrapping 

artifacts in 

the NRRD 

files 

 

 

 

 

 Possible motion artifacts such as the one displayed in Figure 4.5 are often 

apparent in inferior axial slices up through the eye area.  Like all visually 

detected artifacts, these are noted in the Visual QC notes on the wiki. 

 Wrapping artifacts contain one or several “shadow” images that may or may 

not be inverted.  In Figure 4.6, the eyes clearly mark this artifact. 

 

 

Figure 4.7 Pre-frontal anomaly in RD ~.nrrd file, axial and sagittal views 
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 Figure 4.7 demonstrates a pre-frontal anomaly in ~50% of a dataset from a 

Philips protocol. It is mostly visible in axial views, but is occasionally visible 

in the sagittal view as well. 

 If available, the color FA can be loaded on top of the FA ~.nrrd file in ITK 

SNAP for closer examination of such anomalies.  Go to File>Open RGB 

Image.  Click “Browse” to find the appropriate color FA ~.nrrd file 

 

Figure 4.8 Pre-frontal anomaly in FA_color ~.nrrd file, 

Axial view in ITK SNAP 

 

 

This is the same case and anomaly as in Figure 4.7, but 

viewed in the FA color file.  The red arc showing in the 

pre-frontal area is not a result of anatomy and may be 

examined in Slicer for further evidence in determining 

whether the anomaly is anatomical or acquisition-

based.  

 

 

 

 

 

 

 

 Figure 4.9 displays evidence of both wrapping artifacts and pre-frontal 

distortion-related signal loss.  A similar type of artifact is shown in the 

posterior part of the occipital lobe in Figure 4.10 

 

Figure 4.9 Wrapping artifacts, anterior pre-frontal signal loss, and frontal distortion shown in AD 
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Figure 4.10 Posterior occipital signal loss 

 

 

II. Upload of Report to TrackHD 

 A. Login to the TrackHD website: https://www.track-hd.net/html/login 

 i.  Under the individual subject’s page, go to V3 and then click on the MRI  DTI QC bar 

to go to the QC page.   

 ii. After selecting the appropriate Quality Control Result (pass, fail, or borderline), upload 

a PDF version of the ~QCReport.txt created by the DTIPrep QC protocol. 

 iii.  In the Quality Control Comment box, record all QC notes that should already be on the 

wiki page, including coverage issues, percentage of gradients automatically excluded by 

DTIPrep, gradient numbers of manual exclusions, and Visual QC notes in the QC note 

field before submitting the report 

 


